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Working With This Template

This document serves as the basis for detailing an application use case. Unless indicated all sections of this document are required. No section is to be deleted. If a section is not applicable then an explanation of why it contains no information may be entered into that section.

Angled brackets ‘<..>’, indicate text that needs to be replaced in this document. Replace the text within the brackets with the appropriate text and remove the brackets.

There are several predefined styles that are embedded in this template. To display styles, display the document with an outline of 1” or larger. Every item (be it a paragraph, sentence, word, character or object) in this document is assigned with a style. To display all styles that are available to this document, display the (formatting and) styles window, and make sure that all styles available to the current document are selected for display.

Text whose style is of type ‘Template Text’ is included is included to provide guidance to the author and should be removed prior to publishing to the document. Template text provides guidance and examples from various external sources and is not meant to be used within a document as is. To remove template text, select all text of style ‘Template Text ..’ and press ‘Delete.
To customize property fields (which display with a gray background when selected), select File->Properties and click on the ‘Custom’ tab. Replace the ‘Project Name’, ‘Document Type’, ‘Document Name’, ‘Application; and other predefined fields with the appropriate information for this document. After closing the dialog box, automatic fields may be updated throughout the document by selecting Edit->Select All (or Ctrl-A) and pressing F9, or simply click on the field and press F9.  This must be done separately for Headers and Footers.  Alt-F9 will toggle between displaying the field names and the field contents.  See Word help for more information on working with fields.

To add a property to the document, place the cursor at the location where you want the property value to appear and select the ‘Insert->Field’ command. Select ‘Document Information’ and select ‘DocProperty. The custom fields are displayed and may be selected for insertion into the document.
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1 Introduction

This section serves as an overview of the use case. SUBJECT   \* MERGEFORMAT 
1.1 Purpose

The Application Use Case (AUC) document captures the details of the Document Name use case for the Application Name application.
1.2 Audience

For each role that is expected to review this document describe how this document is useful to their role.

example: 
Developers –May use this document to gain an understanding of the requirements for the system.
Project Managers – May use this document in order to track, scope and estimate the effort for the project.
Testers – May use this document to help identify test cases for the product.
Subject Matter Experts – Will use this document in order to confirm that the system will satisfy the business needs.
1.3 Scope
This document contains the details that specify a single use case for the Application Name application and its supporting requirements.
Contains an overview of the information in this document.

example:

This document contains a description, actors, step details, interfaces and supplementary requirements for the Document Name use case.
1.4 Definitions, Acronyms, and Abbreviations

See the project glossary for a complete list of terms used on this project.

1.5 Goals
This section describes the purpose of this use case.

example:

The intention of the Order Form Menu use case is to allow a customer to order from the restaurant menu while seated at a table.
2 Document Name Use Case Details
This section details the use case.
2.1 Brief Description
A short description of the use case focusing on how it enables actors to achieve their goals.

Insert a use case diagram.

Example use case diagram:
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Figure 1 : Example Use Case Diagram
2.2 Usage
Indicate the normal and peak frequency that this use case can be expected to execute.

2.3 Actors

Actors are the roles and systems that interface with the use case.
Actor definitions are located in the project repository.
2.3.1 Primary Actor
The actor initiating the use case is 

List the role or system that triggers the use case.

example  

 Customer – orders a meal from the menu.
2.3.2 Supporting Actors
The following actors interface with the Document Name use case are during its execution:

List all supporting actor roles in this use case.

example
Kitchen (Staff) – supply the customer with their requested order.

Head Waiter – Assist the customer with their order.
2.4 Precondition(s)
This is the state of the system before the use case starts. As such it is not checked during execution of the use case, instead it is assumed that it is not possible to execute the use case it the precondition has not been satisfied. (If the system displays an error because something has not previously occurred, do not list it as a precondition, but describe it in an exception flow.) In general a precondition indicates that some other use case has run to completion prior to this use case executing. In that sense a precondition can be seen as the post condition of some other use case. A common example of a precondition is the actor has logged onto the system.

example:

The welcome screen is displayed.
2.5 Successful Post Condition
This is the condition of the system after the completion of the basic flow.

example:

The customer has been paid their bill.
2.6 Alternate Post Conditions

These are the states of the system after traversing an extension flow.
example:

The customer has cancelled their order.

2.7 Basic Flow
1. <enter use case steps here>
Type each line of the use case using the 'Normal text’ style. When complete, set each step to style 'Use Case Step'. This will automatically number the steps.
The basic flow is the normal flow of events that this use case is intended to execute.

If system does multiple things in no particular order use MS Word’s column feature to show the steps occurring side-by-side, as shown in the following example.

Identify the end of a basic or alternate flow by typing the words 'The use case ends'.
When including another use case, reference the use case name (and identifier) in the step, for example Perform AUC21:Browse Menu use case.
Example: 

The use case starts when:
1 The customer initiates communication with the system.

2 The system displays the instructions screen to the customer.

3 The customer selects the menu.

4 The system displays menu categories to the customer.

5 The customer selects a category.

6 The system displays a list of category items to the customer.

7 The customer selects items to order from the category.

8 The system displays ordered items to the customer.

9 The customer places their order.

10 The system displays the order and requests confirmation that it is correct, to the customer.

11 The customer confirms the order.

12 The system displays the order confirmation to the customer
13 The system displays the order request to the kitchen 

14 The kitchen indicates that the order is ready
15 The system clears the order from the kitchen display and displays the bill to the customer.
16 The head waiter informs the system that the customer has paid their bill.

17 The system displays the receipt to the customer.

The use case ends.
2.8 Alternate Flows

A.1 <Enter alternate flow name here>
2. <enter alternate steps here>
Alternative flow is as the name suggests, a different path a use case can follow to reach a successful post condition. It starts with a condition (which is stated in the Alternative Flow title) and contains a set of steps describing what happens under that condition.

An alternative flow begins by referencing the step or steps from which it branches and the conditions under which the branch occurs. It ends by returning to the basic flow at a specified step, with the words ‘The use case continues from step x.’
Enter alternate flow heading  and text using the 'Normal body' style. Do not reference steps in the use case yet. Set the alternate flow heading to style 'Alternate Flow'. Set each alternate flow step to style 'Alternate Step'. 

Where an alternate flow step makes reference to a step in the use case body, use the 'Insert->Reference->Cross Reference' command to reference the paragraph number.

Where an alternate flow is referenced from a basic step, use the 'Insert->Reference->Cross Reference' command to reference the paragraph number.

When the extension point is documented in its own use case document, reference the use case name (and identifier) in the step, for example Perform AUC11:Call For Assistance use case.
Example:
A1
Customer Changes Page

18 At step 5, the customer changes the page on the menu.

19 The system displays the selected page menu items.

The use case continues from step 4.
2.9 Extension Points
E.1. <Enter extension flow name here>
3. <enter extension steps here>
Extension points are branches from within the flow of events of the use case steps at which alternative behavior may occur.
If the extension point is non-trivial, it is probably better to document extensions to a use case in their own use case document. Indicate that the use case is extended by using the extend-relationship to connect the use cases in a use case diagram.
‘An extension point flow begins by referencing the step or steps from which it branches and the conditions under which the branch occurs. It ends with the words, ‘The use case ends’.

Enter an extension point flow heading and text using the 'Normal body' style. Do not reference steps in the use case yet. Set the alternate flow heading to style ‘Extension Flow'. Set each flow step to style ‘Extension Step'. 

Where an extension flow step makes reference to a step in the use case body, use the 'Insert->Reference->Cross Reference' command to reference the paragraph number.

Example:
E1:Customer Changes Order

20 At step 5,7,9 or 11, the customer cancels their order.
21 The system informs the head waiter that the customer requires assistance.

The use case ends.
2.10 Activity Diagram

The following diagram represents the steps of the use case. The inputs are represented by control flows between activities. The activities represent the work done by the system. The initial state represents the precondition of the use case and the final states are the postconditions. Alternative and extension flows are represented by decisions. Where an alternative flow returns to the basic flow it is represented by a merge.

Place an activity diagram here that describes the use case flow.
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Figure 2 : Example Activity Diagram
3 Use Case Supplementary Requirements

The following supplementary requirements impact this use case. They are gathered here during the detailing of the use case and should be moved to the supplementary folder of ReqPro once the use case has been imported to ReqPro.

<insert supplementary requirement here>
Example:

At step 6: There may be from 1 to 16 different Menu categories.

3.1 Use Case Performance Requirements

The following requirements apply to the steps of the use case. Every system step in the use case should have an associated timing. That timing may apply to an individual step or to a group of steps, so long as every step is covered.

<insert performance requirement here>
Example:
At step 12: When a customer confirms an order the kitchen will be informed within 30 seconds.
3.2 Interface Requirements

Where the use case interfaces with another actor, reference the appropriate standards for developing that interface. The reference may be to an industry standard, company standard or a 'to be developed' interface document.

[An interface should be described in its own separate interface document, and not in the use case. Interface requirements are not imported into ReqPro.]
<insert interface requirement here>
Example:

At step 6 and 18: Items display to the customer in a category will be those selected for today’s menu in the menu database system. The interface specification for accessing menu database items is described in TBD document.
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